I am getting the error "Application cannot be started" when I try to launch the webstart application

From Array Suite Wiki

Jump to: navigation, search

Overview

You may experience an error ("application cannot be started") when trying to start Array Studio using the web start application.

Possible Cause #1: TLS1.2 support for NET3.5 not enabled

Enable TLS1.2 for .NET3.5 - Recently, GEO only supports TLS1.2 security for HTTPS (i.e. for downloading microarray projects). To enable users to download data directly through ArrayStudio, we have added TLS1.2 support for these downloads. Since ArrayStudio requires the Microsoft NET3.5 framework, this requires an update to allow TLS1.2 support for NET3.5. For users that have automatic Windows Updates, this should already be installed. If you get the "application cannot be started" error and do not have automatic Windows Updates enabled, you can download and install the appropriate patch for your Windows installation:

Windows OS Patch Link
Windows 10 https://support.microsoft.com/en-us/help/3156421/cumulative-update-for-windows-10-version-1511-and-windows-server-2016
Windows 7 https://support.microsoft.com/en-us/help/3154518/support-for-tls-system-default-versions-included-in-the-net-framework
Windows 2012 Server R2 https://support.microsoft.com/en-us/help/3154520/support-for-tls-system-default-versions-included-in-the-net-framework
Windows 2008 Server https://support.microsoft.com/en-us/help/3154518/support-for-tls-system-default-versions-included-in-the-net-framework


Possible Cause #2: Older ArrayStudio Installations

This error is very rare, but does happen occasionally as a result of changes to a machine causing it to be out of synch with Array Studio. To remedy this situation, try the following steps:

  • If you have installed Array Studio, and it is listed in control panel under "Installed Programs" uninstall it.
    • NOTE: Array Studio will not be listed in the "Installed Programs" list if you have previously installed using the "ClickOnce" method.
  • Delete the local cache of Array Studio:
For Windows 2000 and Windows XP the folder location is:
"C:\Documents and Settings\[Username]\Local Settings\Apps\2.0
For Windows Vista and Windows 7 the folder location is:
"C:\Users\[User_Name]\AppData\Local\Apps\2.0"
  • Delete all folders EXCEPT "Data" folder (you should see at least one folder that starts with random characters which should be deleted).

LocalArrayStudioFolder.png

This should correct the issue of Array Studio failing to start.